Sponsor

MU Legend CBT Feedback

By: ig4c posted at Mar 13, 2017 1:15 am

Category: Review, Game: MU: Legend (MU2), 279 Views

Tags: MU Legend  

- The game uses way too much CPU power. My i5-4590 is maxed out or at least 90% all the time, even at the title screen. The only people who don't seem to have this problem are i7 users.

- GPU is fully loaded by default. My GTX 1060 ran at like 84°C before I found how to lock the fps at 60 with V-Sync. But even that doesn't seem to be enough as there are often way too many people on the screen to hold a steady 60fps.

- I think you should add a 'reconnect' button or something to special rooms, since i lost many tickets to the several crashes i had. Also the fps drops very hard after having the game open 30/50 mins

- The Blood Castle countdown starts BEFORE the whole party enters the dungeon. This often leads to 30-40 seconds deducted from the results, which is very discouraging.

- The word "auto" is censored in chat. Please fix your word filter.

- When you move from a map to another, if you click on a dungeon (for example a rift) before the whole map is fully loaded, you will enter the dungeon immediately instead of getting the screen to pick difficulty and party. I accidentally wasted an entry for Dragon's Haven because of this. Please fix it.

- The fonts used in CBT1 looked very nice, but now all the fonts look like Arial. Why changed the original when it was much better?

- The imperial coins seller been spamming such as gm2v mu legend zen. If the devs do NOT combat this issue soon, this game will suffer huge player drop offs.

Bookmark and share to your friends

Comment (0) Like it (  0  )
Loading...
Name:
Attach: Emotion Photo Video
Score:
Vote:
  • Pub:
  • Dev:
  • Fee:
  • Area:
  • Status:
  • CB Date:
  • OB Date:
  • Release:
  • Hot:
  • Genre:
Follow 0 followers
Blog Post RSS